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President and Founder, YourPresenceOnTheWeb.com

Class 3Class 3

Please have a seat, fire up your laptop,
connect to the wi-fi and download the class slides

Wifi Connection:
Network name:  tomil         Password:  agent007

Slides are posted here:
http://YourPresenceOnTheWeb.com/jan16bootcamp

Password:  winter
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Agenda for Class 3
   

● Quick Review of Week 2
● Migrating a Site to a New Hosting Environment
● Using Plugins
● More about Blogging
● More Ways to Creatively Capture/Display Content
● Using the Media Library
● Managing Users
● Other Settings of Interest
● Closing Remarks
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Quick Review of Week 2

● Last week we covered:
● Maintaining Current Software

● Wrap Up Creating Custom Menus

● Setting the Home Page

● More on Editing Pages and Posts

● Using Themes

● Using Widgets

● Any questions about any of this, or the homework?
● Did anyone try to install the TinyMCE Advanced plugin?
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Migrating a Site to a New Hosting Environment

● Migrating a site must take into account
● The WordPress file structure
● The MySQL database
● The settings in the wp-config.php file
● Ensuring the URLs in the migrated site point to the right

place
● Adjust the migrated site to include any content not

migrated (e.g., themes, plugins, widgets)
● Various tools and techniques can be used to migrate a site
● The best process will depend on:

● What environment you are migrating from and to
● How much of the content you want to migrate
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Migrating a Site to a New Hosting Environment

● Three-step process:
1) Pick and register a domain name
2) Establish a hosting account
3) Migrate the Content

● Step #1: Pick a domain name that is appropriate for your purposes
AND that is not already owned by someone else

● Use whois.com to determine if the domain name is
available

● If the domain is available, either:
– Register the domain name yourself with a domain

registration vendor, e.g., Namecheap.com
           OR

– Register the domain when you create an account
with your hosting vendor (see below)
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Migrating a Site to a New Hosting Environment, cont'd
● Step #2: Establish a hosting account with a reputable vendor

● Wordpress.com – free option is fine for a personal blog or a
very simple “marketing brochure” type of site, assuming you
can live with the limitations (e.g., limited theme choices, no
plugins, no customer service).  Can also purchase “upgrades”
to support more features, services.

● Recommended private hosting vendors for start-up sites:
– InMotion – use this link for 38% discount off basic plan (“Launch”):

https://secure1.inmotionhosting.com/cgi-bin/gby/clickthru.cgi?
id=linkomatic

– Siteground – use this link for 60% discount off basic plan (“Startup”):
https://www.siteground.com/index.htm?
afcode=c18e3b7101c5daa3312c8b42c6ffb91c

– O NOT use any vendors owned by EIG – e.g., Bluehost,
HostGator,Fat Cow, HostMonster. For complete list see:
http://www.webhostingsecretrevealed.net/blog/hosting-updates-
news/the-who-what-when-of-endurance-international-group-eig/

● May need certain “extras” depending on the type of site, e.g.,
SSL certificate for e-Commerce site
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Migrating a Site to a New Hosting Environment, cont'd
● Step #3: Migrate the site via one of the following options

● Option #1: Let the hosting vendor do it (easy, complete,
but not universally available)

● Option #2: Manually export/import the content (moderately
difficult, and does not transfer all features/settings)

● Option #3: Manually transfer the wp-content folder
(complete, universally available, but difficult)
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Migrating a Site to a New Hosting Environment, cont'd
● Step #3 – Option 1: Let your hosting vendor do the migration

– Some vendors will migrate a site from another
hosting environment to an account in their
environment for free

– Restrictions may apply, e.g., it must be a brand-
new account, may only support migrations from
other vendors using cpanel, a limit may exist on
the number of free transfers

– Need to provide the vendor with login credentials
for the account where the site is currently hosted

– The upside: you won't have to re-install/configure
themes, plugins, widgets, custom menus, etc.

– CONTACT ME if you want to try to go this route
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Migrating a Site to a New Hosting Environment, cont'd

● Step #3 – Option 2: Manually export/import the content.
● Downside: only content (e.g., pages, posts, media) will transfer
● Step #3.1:  Perform a fresh install of WordPress in the new hosting

environment – either:
a) Utilize “one-click” WordPress install provided by many

hosting vendors, OR
b) Preferred method: follow the “Famous 5-Minute Install”

process
(see:
http://codex.wordpress.org/Installing_WordPress#Famou
s_5-Minute_Install ).

● Requires ability to use FTP, set up MySQL
database

● Step #3.2: On the original site, use Tools => Export to export the
content into an .xml  file
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Migrating a Site to a New Hosting Environment, cont'd

● Step #3 – Option 2: Manually export/import the content
● Step #3.3: On the new site:

1) Install the WordPress Importer plugin and use Tools =>
Import to import the .xml file to the new site.  (Be sure to
select the option to pull across the media referenced in
the pages/post.)

2) Install the theme and plugins of your choice; configure the
theme, custom menu(s), plugins, widgets and other
general settings as appropriate
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Migrating a Site to a New Hosting Environment, cont'd

● Step #3 – Option 3: Manually transfer the wp-content folder
● Too advanced for this class
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Plugins are....

Fun

Fabulous

Frightening

Full of functionality

Full of security
holes

Able to help find security
holes

Frustrating

Really 
Frustrating

Easy to find

Hard to find

Free

Pricey
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Plugins are....

Fun

Fabulous

Frightening

Full of functionality

Full of security
holes

Able to find security
holes

Frustrating

Foiling

Easy to find

Hard to find

Free

Pricey

A: All of the above!  But don't let that scare you away-- 
the challenge is worth the effort!
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Using Plugins
What is a Plugin?

“Plugins can extend WordPress to do almost anything you
can imagine.” - wordpress.org

● Over 42,000 free plugins are available at http://wordpress.org/plugins, with
many more premium plugins available from various software vendors

● Plugins can: add or modify visual elements, add more controls to
admin panel screens, enhance performance of the site, connect the site
with social media, add custom post types and other database tables,
add features to page/post editing....the list is endless!

● When installed and activated, a plugin may:
● Add one or more widgets
● Create new menus or sub-menus (e.g., under Settings) in the

admin panel
● Add new attributes/icons on the page/post editing window, or...
● Change the appearance/operation of your site in some other way
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Exercise #13:  Installing Plugins
NOTE: Installation and activation of plugins is similar to how you manage themes, except 
you can have many plugins active at a time, not just one.
1) Navigate to the Plugins => Installed to see the plugins that have been installed
2) Note the links at the top that filter the plugins displayed (All, Inactive, etc)
3) Click on Add New button to display the Add Plugins screen.  As with themes you

may either install a plugin directly from wordpress.org, OR upload a plugin file.
4) To install a plugin from wordpress.org use one of the options to find the plugin you

want: either Search by keyword, or use one of the links (Featured, Popular,
Recommeded, or Favorites ) to filter the list of plugins displayed.  Example: search
for the plugin named “TinyMCE Advanced”.

5) When you find the plugin you want, click on the Install Now button and click Okay to
confirm the decision.  You will then have the option to Activate the plugin.  (Note:
Inactive plugins have no effect on a site, other than to add “bloat” and potential
security vulnerabilities.)

6) If you want to install a plugin purchased from a vendor, you will need to first download
the .zip file to your hard drive.  Then, when you get to the Install Plugins screen, click
on the Upload link. On the next screen, click on Choose File to open a file browser to
locate and upload the .zip file from your hard drive.

7) Once a plugin is installed, in most cases you will need to configure it in some way in
order to use it.  How you do this varies by plugin.  Refer to the plugin
documentation on wordpress.org or on the plugin vendor site for details.
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Using Plugins
A Few Popular Free Plugins

● Akismet – rejects spammy user-submitted comments (installed by default)
● Jetpack by WordPress.com – a smorgasbord of miscellaneous

tools/features brought to you by Automattic, the owner of WordPress.org
(need to link your site to a wordpress.com account)

● Ninja Forms – a tool to create input forms that can be embedded in a
post/page

● Google XML Sitemaps – automatically build a sitemap that helps search
engines crawl your site

● W3 Total Cache – adds an array of caching capabilities that can improve
site performance

● WordPress SEO by Yoast – tools to help optimize your site for “search
engine-friendliness”

● WP Edit or TinyMCE Advanced– adds a bunch of useful tools to the
visual editor menu 

● Image – adds an easy-to-use widget to display images in the Media
Library
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Using Plugins
Consider using a Page Builder type of plugin

● Some themes, such as my favorite, Divi from Elegant Themes,
include a “page builder” feature, which provides a powerful, flexible
way to extend the ability to add, maintain and layout content when
creating/editing pages and posts

● If your theme does not include this feature, you can install a plugin
that provides it.  Some examples:

● Premium
– Divi Builder (Elegant Themes)
– Visual Composer (Code Canyon)

● Free
– Page Builder by Site Origin
– Beaver Builder - WordPress Page Builder
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More About Blogging
The Case for Blogging

● Encourages repeat visits by continuously adding new, fresh content 
● Enhance your perception as a subject matter expert
● Enhance your brand
● Can allow users to subscribe to new content published on the blog
● One of the best ways to build a sense of community around your site
● Blogs are a great way to relate entertaining stories and informed

opinions, which people love to read 
● Blogs enhance search engine friendliness of the site by reinforcing

keyword phrases and attracting “link bait” (links from other sites)
● You can use blogs posts to creatively display different types of

content
● Article supporting blogs for business websites:

http://www.libelcom.com/marketing/designs/why-should-a-business-
website-have-a-blog/
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More About Blogging
Using Categories and Tags

● Assigning Categories and/or Tags to your posts can help readers
(and search engines) readily recognize and find topics of interest in
your site

● Categories and Tags apply only to posts, not to static pages
● Categories tend to be used to label articles by broad topics; Tags

often are used for narrower topics – but there are no “hard rules”
● Categories are managed under Posts => Categories.  Tags are

managed under Posts => Tags
● One or more Categories or Tags can be assigned to a given post.

● If you do categorize/tag posts, it's best to do it immediately when
you create the posts

● By default posts are assigned to “Uncategorized” category
● A reader can see the Categories/Tags assigned to a post when they

are viewing the post or blog page
● When a reader clicks on a Category/Tag link, an “archive page” will

be displayed containing all posts with the same Category/Tag
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More About Blogging
Adding Posts to Menus and Sidebars

● Under Appearance => Menu you can create a menu item that
points to an archive page (a.k.a., a “mini-blog”) that displays:

● A single designated post, or
● All posts assigned to given Category or Tag

● Various Widgets also are available to display filtered lists of posts
or “clouds” of Category/Tag names in a sidebar.  For example:

● Archives
● Categories
● Category Cloud
● Tag Cloud
● Custom Menu
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Exercise #14: Creating Menus for Archive Pages
Objective: Add tabs to a menu for archive pages

NOTE: Before you start, make sure you have at least one Category and one Tag
defined, with one or more posts assigned to each one.

1) Navigate to Appearance = > Menus, then click on the Screen Options tab that appears at the
top of the screen to expose the panel you can use to show/hide certain fields on screen. Make
sure the boxes next to the Categories, Posts and Tags fields are checked, and click on
Screen Options again to close that panel.

2) To add tabs that link to a “mini-blog pages” for particular categories: In the Categories section
on the left side of the screen, click the box next to each of the Categories of posts that you want
to appear in the menu, click on the Add to Menu button, then, on the right side of screen,
position the Category tabs where you want them.

3) To add tabs that link to a “mini-blog pages” for particular Tags: In the Tags section on the left
side of the screen, click the boxes next to each of the Tags that you want to appear in the
menu, click on the Add to Menu button, then, on the right side of screen, position the Tag tabs
where you want them.

4) To add a tabs that point to individual posts: In the Posts section on the left side of the screen,
click the box next to each of the post articles that you want to appear in the menu, click on the
Add to Menu button, then, on the right side of screen, position the post tabs where you want
them

5) Click Save Menu, then navigate to the front-end view of the site to view the results.
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More About Blogging
Enabling/Disabling/Moderating Comments

● Comments allow visitors to engage in discussions about posts and pages
● Many sites enable comments for posts, but disable comments for

static pages
● To enable/disable comments by default when you create a new post or

page:
● Go to Settings => Discussion and check/un-check Allow people to

post comments on new articles (does not affect existing articles)
● To enable/disable comments on a particular page/post:

● On the Add (or Edit) New Page/Post screen, check/un-check the Allow
Comments box in the Discussion section (If necessary, expose the
Discussion section via Screen Options.)

● Control various features of the commenting process via the Other
comment settings on the Settings => Discussion screen
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Most About Blogging
Other Capabilities

● Many plugins are available to enable/leverage/enhance blog
content 

● Most notably: Jetpack –  submit posts by e-mail, automatically
submit posts to social media, deliver e-mail notifications for
new posts, record the number of “likes” by visitors, allow
visitors to share/like posts via social media, and more

● Some themes have special features supporting posts, e.g.,
● Setting a Sticky Post flag on a post forces it to “stick” to the top

of the blog page
● Post Formats provide a way to style posts of a certain type in a

particular way
● Use the MORE tag to make long posts more reader-friendly
● Set dates in the future for publishing posts (or pages)
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More About Blogging

● For more general info & guidance about blogging, see:
https://codex.wordpress.org/Introduction_to_Blogging
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More Ways to Creatively Capture/Display Content
Embedding Cool Content

● It is possible to embed all manner of other media stored on other
sites in a page or a post.  A few examples:

● YouTube videos
● Vimeo videos
● Google+ calendars
● Google+ posts
● Google maps
● Flickr photos

● Two different method to perform embeds
●  Links to media items are pasted into a page/post in Visual mode
●  Code snippets are pasted in Text mode

For more information about embeds:
https://codex.wordpress.org/Embeds

For more information about embeds:
https://codex.wordpress.org/Embeds
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Exercise #15: Embed a YouTube Video
in a Page or Post

1) Open a new or existing post or page.  Edit the article in visual mode.
2) Open a new tab/window and navigate to YouTube.com and find a video

you would like to embed in your article.
3) Click on the Share button under the video, click in the field with the URL

for the video and copy the value into your paste buffer
4) Return to the post/page editing screen.
5) Place your cursor at the end of the last line of copy before where you want

the video to be located, and click the Enter key to skip down to a new line.
 (NOTE: The link to the YouTube video must be on its own line.)

6) Paste the contents of your paste buffer onto the new line.  A preview of the
video will appear in the editing window.

7) Click on Save Draft, then click the Preview button to see the video
embedded in the article.

8) Click on the Play (right arrow) button to play the video – which can be
manipulated in all the same ways as if you were viewing it in YouTube,
e.g,. full-screen, pause, volume.
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Exercise #16: Embed a Google Calendar
in a Page or Post

1) Open a new or existing post or page.  Edit the article in text mode.
2) Open a new tab/window, navigate to Google Calendar and login.
3) Go to Calendar Settings, drill down on the calendar you want to display

and click on the Calendar Details tab.
4) Click in the field with the embed code, select all the code and copy the

code into your paste buffer.
5) Return to the post/page editing screen.
6) Place your cursor at the end of the last line of copy before where you want

the calendar located, and click the Enter key to skip down to a new line.  
7) Paste the contents of your paste buffer onto the new line.
8) Click Preview to see how the calendar will display on the page.

NOTE: If the settings for the Google Calendar you are embedding are not
already set to allow sharing of the calendar, you will need to make that
adjustment, too, before the calendar will display on your website
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More Ways to Creatively Capture/Display Content, cont'd

● Creative use of settings in the Appearance => Customize menu.
(Availability varies by theme.)

● Custom Logos and/or Favicons to add brand identity
● Built-in Sliders to display rotating carousels of images w/text

captions
● Ways to modify the default fonts, e.g., font family, color,

size, weight
● Change the default page layout, e.g., add/hide/move

sidebars
● Add custom CSS code



 

Page 29 of 44
Creating Websites with WordPress

Class #3
@copyright 2016

More Ways to Creatively Capture/Display Content, cont'd

● Other cool features supported by some/most themes
● Featured Images can be used to display a custom header

image on a static page or to highlight a post, e.g., on the
blog page

● Predefined Page Templates alter the layout (and
sometimes the content) of a page

● Use Custom Post Types and Custom Fields to maintain and
display databases of objects with common elements, e.g.,
books, recipes, real estate, artwork....

● Example using the Pods plugin to capture/display the
product pages at  http://nutfieldtech.com
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Using the Media Library
● Navigate to Media => Library to see a list of all media that have

been uploaded.
● From this screen, you can view information media items and/or edit the item,

as well as upload new items

● See which media are attached to articles and which are not;

● View various attributes of the media (e.g., date/time uploaded, file
name, file type, dimensions, 

● Edit certain attributes for each item (e.g., default caption, alt text
and description)

● For images, perform basic edits on the actual image (e.g., re-
orient/scale/crop the image)

● Delete items from the library
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Using the Media Library, cont'd
● All manner of media files can be stored in the Library: e.g.,

images, video files, audio recordings, PDF files, other
documents

● Several ways to upload a file into the Media Library:
● Using theme-specific features in Appearance, e.g., custom

backgrounds and header images

● When editing a post/page article:
● Add Media – imbeds the image or a link to the document into the article.

Images can be imbedded as individual images, Galleries or
Sideshows.  A single article may have multiple
images/galleries/sideshows imbedded in it.

● Set Featured Image – makes the image available for display by Themes
that support featured image.

● Using the Media =>  Add New screen to directly upload media files
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Using the Media Library, cont'd
● Regardless of how a file is added to the Media Library, once it is

uploaded it is available for use in any part of the site – you don't
have to, for example, re-upload an image each time you want to
add the image to a page or post

● NOTE: some themes/plugins store media in their own
“libraries” outside the WordPress Media Library

For more information about the Media Libarary:
http://codex.wordpress.org/Media_Library_Screen

For more information about the Media Libarary:
http://codex.wordpress.org/Media_Library_Screen

http://codex.wordpress.org/Media_Library_Screen
http://codex.wordpress.org/Media_Library_Screen
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Managing Users

● Creating additional users enables one to share the responsibilities of
maintaining a site, and to share content with selected visitors

● Hierarchy of user roles
● Administrator – has access to all the administration features within a single

site, including ability to create other user profiles (most privileged)

● Editor – can publish and manage posts including the posts of other users.

● Author – can publish and manage their own posts.

● Contributor – can write and manage their own posts but cannot publish
them.

● Subscriber –  can only manage their own profile (least privileged)

● Also, for Multi-site installations only: Super Admin – has access to the site
network administration features and all other admin features

● For more details: http://codex.wordpress.org/Roles_and_Capabilities

http://codex.wordpress.org/Roles_and_Capabilities
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Managing Users

● User management is done at the Users Dashboard menu
● Users => All Users to display a list of users and to edit/remove user

profiles
(see: http://codex.wordpress.org/Users_Screen )

● Users => Add New to create a new user
(see http://codex.wordpress.org/Users_Add_New_Screen )

● Users => You Profile to view/edit information in your own user
profile
(see: http://codex.wordpress.org/Users_Your_Profile_Screen )

● TIP: Using plugins, like Restrict Content, allows one to restrict
viewing of content to designated logged-in users

http://codex.wordpress.org/Users_Screen
http://codex.wordpress.org/Users_Add_New_Screen
http://codex.wordpress.org/Users_Your_Profile_Screen
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Other Settings of Interest
● General:  Allow anyone to register themselves on your site, set new user

default role, set date/time formats
(see: http://codex.wordpress.org/Settings_General_Screen )

● Writing: set default post category and format, enable post-by-email
(see: http://codex.wordpress.org/Settings_Writing_Screen )

● Reading: control number of posts to show on a blog page, how posts are
sent to feeds, search engine visibility
(see: http://codex.wordpress.org/Settings_Reading_Screen )

● Discussion: various settings to control commenting, comment notification
and comment moderation
(see: http://codex.wordpress.org/Settings_Discussion_Screen )

● Media: control the max. size of embedded images, designate storage of
images in folders by month uploaded
(see: http://codex.wordpress.org/Settings_Media_Screen )

● Permalinks: change how the permalinks are structured
(see: http://codex.wordpress.org/Settings_Permalinks_Screen )

For more information on the Settings screens:
https://codex.wordpress.org/Administration_Screens#Settings

For more information on the Settings screens:
https://codex.wordpress.org/Administration_Screens#Settings

http://codex.wordpress.org/Settings_General_Screen
http://codex.wordpress.org/Settings_Writing_Screen
http://codex.wordpress.org/Settings_Reading_Screen
http://codex.wordpress.org/Settings_Discussion_Screen
http://codex.wordpress.org/Settings_Media_Screen
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Closing Remarks

● Class slides and sandbox sites will remain available until the
end of February

● If you followed along, practiced the exercises, and did the
homework, you learned enough to be truly dangerous!

● But there is a lot more to learn – I encourage you to:
● Learn the elements of good web design style
● Always remember: new, fresh, relevant, well-written

content is king!
● Include a blog in your site and learn how to blog better
● Cross-promote your site with social and traditional media
● Become an active, curious explorer of the WordPress

universe
● Join a WordPress Meetup, attend a WordCamp
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Closing Remarks
NH WordPress Meetup

● Who:  Anyone with an interest in WordPress – all levels of expertise are
welcome!

● What:  The WordPress Meetup that's closest to you, with presentations and
discussions on topics of interest

● Where: The Farm Bar & Grille, 1181 Elm St., Manchester
● When:  Generally once a month on the second Tuesday of the month
● Why: 

● Meet and network with fellow 'Pressers
● Learn/share a bunch of good stuff about developing websites with

WordPress, being a freelance developer, etc.
● Have fun!
● It's free! (except for any food/drink you order)

● How: Check it out at http://www.meetup.com/WordPressDevNH
● Create a Meetup.com account (free!) and join the group
● Then RSVP to the Meetups as they are announced
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Closing Remarks
WordCamps

● Conferences held all around the world to discuss “all things
WordPress”.  See: https://central.wordcamp.org/

● Great for learning/sharing new stuff and networking – highly
recommended!

● The next national one will be held in December 2016.  See:
https://central.wordcamp.org/wordcamps/wordcamp-us/

● Some local ones:

● WordCamp Boston – Held annually.  Next one will be in
July.  See http://boston.wordcamp.org/

● WordCamp Maine – See:
https://2016.maine.wordcamp.org/
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Closing Remarks
If you want more help from me...

● Individualized tutoring
● Available on an hourly basis at a reduced billing rate ($45/hr

for the first three hours)
● Performed via phone conference using a screen sharing tool

● Advanced Topics in WordPress class & E-commerce Workshop
● Scheduled on an on-demand basis

● If you decide you don't have the time/inclination to build your own
website, I'll build a website for you – which you can
enhance/maintain yourself going forward

● I just did this one for Jeff Murray:
                     http://ecbiz187.inmotionhosting.com/~vinta126/vcr/ 

● Cost depends on size, scope, features, etc of the site
● Will provide a free estimate

● Contact me if you are interested in any of these options

http://ecbiz187.inmotionhosting.com/~vinta126/vcr/
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Closing Remarks
Other Training Class I Offer 

Site Management and
Security

● Options for initially setting up
your site;
● “Hardening” WP security
against would-be
hackers/spammers/phishers
● Safely upgrading software
● Backing up, restoring and
migrating sites
● Creating a locally hosted test
environment
● Improving performance

Enhancing the User
Experience

● Themes with advanced built-in
features
● Great plugins to provide
additional functions, features
and effects
● Safely switching between
themes
● Effective page layouts
● The world of fonts
● Using Custom Post Types
● Making minor code “tweaks”

Attracting and
Converting Traffic

● Basic concepts of Search
Engine Optimization
● Seeing who is visiting your site
and how they are using it
● Simplified SEO tools and
techniques for WordPress
● Setting goals and tracking
progress.

● Advanced Topics in WordPress course: Five 2-hour classes to learn
more essential skills and best practices for creating/maintaining WordPress
sites

http://yourpresenceontheweb.com/advanced-topics-in-wordpress/
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Closing Remarks
Other Training Classes I Offer

● Creating Online Stores with WordPress:
● A ½-day workshop to learn the basics of creating an online store

using Woocommerce, the most popular, very powerful and user-
friendly e-commerce shopping cart

http://yourpresenceontheweb.com/e-commerce-workshop/
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Closing Remarks
Other Learning Opportunities

● Books:

● https://www.elegantthemes.com/blog/resources/top-
12-wordpress-books-to-add-to-your-collection

● Blogs:
● https://www.elegantthemes.com/blog/resources/best-

wordpress-blogs
● Online videos:

● Just Google “WordPress videos about...”
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Closing Remarks
The Student Showcase

● The Student Showcase is a page on my website that exhibits
websites created by students of the Creating Website with
WordPress class

● One your site is “ready for prime time”, contact me if you
would like me to add it to the showcase

To view the Showcase:
http://YourPresenceOnTheWeb.com/student-showcase

To view the Showcase:
http://YourPresenceOnTheWeb.com/student-showcase
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Thank you for giving me the opportunity to share my
love of WordPress with you, and best of luck with

your future WordPress endeavors!

Jonathan May
jwmay@yourpresenceontheweb.com

Http://YourPresenceOnTheWeb.com
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